Mikrotik

Cara Membuat IP Publik Speedy ( dinamic ) via Domain

Sepeti yang kita ketahui bersama ip speedy ( ISP ) sering berganti – ganti bagi anda yang memiliki warnet maupun memiliki fasilitas internet mungkin anda akan kesusahaan di karenakan anda sudah tidak bisa mengakses ip modem anda apalagi harus setiap saat harus menyimpan ip public modem agar anda bisa akses dari mana saja mungkin saat ini sudah ada caranya dimana anda bisa mengakses modem anda dari mana saya asalkan anda mendaftar terlebih dahulu domain anda di www.changeip.com agar ip modem anda bisa di baca oleh change ip dan anda bisa meremote modem anda kapan saja disini saya mencoba mengimplementasi melalu mikrotik anda bisa menamkan scrib di mikrotik anda agar bisa anda akses disini saya akan memberikan gambar tahap – tahap pembuatan acount di www.changeip.com

Bila anda belum memiliki acount id di changeip.com disarankan anda harus membuat dulu acount nya agar bisa anda regester ip public anda agar bisa di akses dari mana saja sesudah anda regestrasi nanti

Setelah anda daftar domain gratis anda bisa di harapkan perikasa terlebih dahulu email anda setelah proses berjalan baik lalu anda prov di email anda setelah itu anda setup password dan user di mikrotik anda jangan lupa isikan scrib nya di mikrotiknya

Lalu anda tambahkan scrib nya di mikrotik isi dari seribnya adalah
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# EDIT YOUR DETAILS / CONFIGURATION HERE
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnsuser “nama account di changeip.com
:global ddnspass “password di changeip.com
:global ddnshost “nama domain yang di buat di changeip.com
:global ddnsinterface “nama interface di mikrotik awah internet atau wan
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# END OF USER DEFINED CONFIGURATION
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

:global ddnssystem (“mt-” . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
:global ddnslastip

:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info “DDNS: No interface named $ddnsinterface, please check configuration.” }

:if ([ :typeof $ddnslastip ] = “nothing” ) do={ :global ddnslastip 0.0.0.0/0 }

:if ([ :typeof $ddnsip ] = “nothing” ) do={

:log info (“DDNS: No ip address present on ” . $ddnsinterface . “, please check.”)

} else={

  :if ($ddnsip != $ddnslastip) do={

    :log info “DDNS: Sending UPDATE!”
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip “/”] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

  } else={ 

    :log info “DDNS: No changes necessary.”

  }

}

# END OF SCRIPT

Setelah kita buat dan kita running di mikrotik anda maka akan bisa kita akses dari luar seperti tampilan di bawah ini.
Silahkan mencoba bagi sobat -sobat yang memiliki modem atau internet di warnet anda .

Join The Discussion